安装sql2008或2005为什么一定要安装.Framwork? 100fredrickhu]

发布时间:2017-1-21 2:02:55 编辑:www.fx114.net 分享查询网我要评论
本篇文章主要介绍了"安装sql2008或2005为什么一定要安装.Framwork? 100fredrickhu]",主要涉及到安装sql2008或2005为什么一定要安装.Framwork? 100fredrickhu]方面的内容,对于安装sql2008或2005为什么一定要安装.Framwork? 100fredrickhu]感兴趣的同学可以参考一下。

最近公司打算升级数据库,今早打算安装sql2008,提示说要先安装.Framwork,去网上搜了一下,全是.net和Sql2005的组合。非常的困惑, 安装sql2008或2005为什么一定要安装.Framwork?难道微软出的sql2005以上版本都只是为了VS.Net来服务的? 像VB6或者Dephi等这些开发C\S软件的语言只用sql2000就到头了吗?

必须的

SQL 2005和2008都是基于.net开发的

要玩游戏只能遵守游戏规则...

sql2005跟VS有暧昧,所以必须装

SQL2005/2008这么大家伙都装了,还在乎一个几十MB的donet framework?

framework=运行环境+类库 。     是sql2005,08的运行环境。如同JAVA的JDK。

SQL 2005需要donet framework 2.0支持

这个是必须的。它是一个环境~

呵呵,没想到这么快就有人回答了,我还以为要等很久呢。 主要是考虑到如果要装sql server 就要装framework,会增加实施人员的工作量,而且有时候framework装不好,sqlserver就连不上。 就怕又出现ADO连接数据库时在某些客户的机子上总是要提示“找不到可插入的ISAM ”等不稳定的因素存在。 又比如我在安装.net的时候,总是有些这样那样的小问题出现。反正挺烦人的。

呵呵,我还没说清楚,就是我们的程序是VB6写的,用framework这个环境没用呀,又不是用VS.net写的可执行文件。

这么说,我们的工程就用VB和sql2000好了,没必要再升级sql2005了?

[北京睿朗阳光诚聘资深LINUX系统管理员] 工作要求: 1.计算机或相关专业本科以上学历,英语优良。 2.五年以上linux/unix/BSD管理经验。拥有大型网站尤其是大型JAVA-based网站的集群以及管理经验。熟悉linux/unix 的管理,配置,备份及灾难恢复。熟悉集群的架设,负载均衡的设置。 3.精通Mysql/Oracle,有相关数据库集群的架设经验,具有数据库优化经验。 4.精通Apache TOMCAT/Jboss 的各项管理配置。 5.精通C shell or Perl,精通各种Linux/unix 下软件的使用,如SSH SSL Iptables等。对网络安全有比较深刻的认识。能有效地防范网络攻击。 北京睿朗阳光网络科技有限公司,是提供综合性彩票服务的龙头企业集团,拥有国际化的彩票系统技术解决方案,服务于东南亚、欧洲,及非洲多个国家。面向国内,旗下现有我中啦(www.wozhongla.com)、全国114彩票服务平台(http://www.114caipiao.com)、江西福利彩票服务平台(http://www.loto.jx.cn),以及上海福利彩票服务平台(http://www.loto.sh.cn)。 2007年,公司实现销售额从零到4000万元人民币/月的骄人业绩,年收入达3亿多元人民币。 2008年,公司成功地完成了从互联网彩票服务平台向手机、固话、互联网彩票综合服务平台的转型。为公司进一步的发展奠定了坚实基础。 2009年,睿朗阳光正以全新的姿态蓄势待发,现提供优厚的薪金和福利待遇以及良好的发展空间,诚邀优秀技术开发人才的加盟! 联系方式: 地址:北京市朝阳区东三环中路39号建外SOHO8号楼  邮编:100022 邮箱:[email protected]   UID2010081 帖子3 精华0 积分16 经验值130 点 阅读权限10 在线时间0 小时 注册时间2009-6-24 最后登录2009-6-24 查看详细资料  编辑 引用 评分 回复 TOP   

MS的产品结合会越来越紧密。 SQL2005以上版本必须要用FRAMEWORK的原因就在于SQL可以通过扩展存储过程来调用很多.NET framwwork业已封装的功能。 从而更大程度上加强SQL2005的功能,理论上可以无限扩展。 而且也让大家以后对MS的产品产生更大的依赖 。

微软的东西都封装在一起了,LZ的名字很熟悉,在哪见过

引用 3 楼 josy 的回复:要玩游戏只能遵守游戏规则...  经典!!!!!

呵呵,大伙儿能不能讨论一下,我们的工程VB和sql2000有没有没必要升级sql2008?我现在有些迷糊。总觉得好像升了之后没多大好处。

IIS是集成在软件中,便于开发人员开发使用的,装2008的时候还有VS2008的安装呢,呵呵

2008要安装3.5版本,2005要安装2.0版本。

引用 2 楼 fredrickhu 的回复:SQL 2005和2008都是基于.net开发的 up

引用 3 楼 josy 的回复:要玩游戏只能遵守游戏规则... 你可以不上公车 但要遵守交通规则 是这个意思吗

引用 3 楼 josy 的回复:要玩游戏只能遵守游戏规则... 是这样的

引用 2 楼 fredrickhu 的回复:SQL 2005和2008都是基于.net开发的 引用 3 楼 josy 的回复:要玩游戏只能遵守游戏规则...

这是没有办法的,再说也不是很大,装上呗

引用 16 楼 lynays 的回复:呵呵,大伙儿能不能讨论一下,我们的工程VB和sql2000有没有没必要升级sql2008?我现在有些迷糊。总觉得好像升了之后没多大好处。2008比2000更安全,高效。但同时硬件要求也高。

引用 24 楼 ai_li7758521 的回复:引用 16 楼 lynays 的回复: 呵呵,大伙儿能不能讨论一下,我们的工程VB和sql2000有没有没必要升级sql2008?我现在有些迷糊。总觉得好像升了之后没多大好处。  2008比2000更安全,高效。但同时硬件要求也高。 有没必要升级2008 需要综合你软件使用环境来考虑吧~

微软规定的

sql2005, 2008 需要安装 Framwork,但并非只是为了VS.Net来服务的。 像VB6或者Dephi等这些开发C\S软件的语言也能用sql2005,2008,只需在服务器端安装 Framwork。 

遵守游戏规则

sql server 2005 的客户端开发使用c#开发的,c#程序要正常运行,必须在自己的框架(.net framework)平台上,所以必须要装.net framework

我进过的企业现在只是升级到2005

有老婆就有老公.

因为程序是基于.net framework开发的    ------------------------------------- 分享网络资讯 www.yeahbeta.com  有空来踩踩

有了framework才能运行

用vb6开发的,那么只需要服务器端安装.net,客户端不必。

2005,2008都是基于.Net framework的,vS.Net只是.Net上的开发工具而已.

ms 的

所以说微软的产品只能在WINDOWS系统上跑跑,它就像把咱们捆在它的平台上

因为它们和vs都是一伙的

既然你是开发VB的 用SQL2000就足够了 SQL2005主要是方便用VS开发网站的

貌似安装sql2005时自动会安装 framework2.0的平台···

就是呀,为什么要用.NEt framework呢.>>一个数据库软件说不过去呀??

引用 2 楼 fredrickhu 的回复:SQL 2005和2008都是基于.net开发的.

引用 41 楼 zjh222 的回复:就是呀,为什么要用.NEt framework呢.>>一个数据库软件说不过去呀?? 装一个数据库软件还要安装MS的操作系统,是不是更说不过去呀?

.NET framework是个好东西,我电脑没这个的话,好多下载的东西都用不了 装个win sever 2008里面就带了.net framework 3.0了,方便

哈哈

应该是sql2005以上版集成了clr吧

该回复于2010-01-19 17:30:10被版主删除

你要用就要装,没什么好说的

那安装2000就行了,何必安装2008,安装了又来问问题,说不出来了

如果没有windows系统,就不能装sqlserver,一样的道理。

上一篇:多媒體資料庫的疑問 40ctjh900801]
下一篇:05 的数据库如何在 SQL 2008R2 /SQL 2005 之前备份还原使用 40bean_sql]

相关文章

相关评论