好贷网好贷款

The current deployment target does not support automated __weak references

发布时间:2016-12-5 18:30:58 编辑:www.fx114.net 分享查询网我要评论
本篇文章主要介绍了"The current deployment target does not support automated __weak references",主要涉及到The current deployment target does not support automated __weak references方面的内容,对于The current deployment target does not support automated __weak references感兴趣的同学可以参考一下。

4.2以前版本的XCode都不支持ARC。 对操作系统也有要求:Mac OS X v10.6 或 v10.7 (64-bit applications), iOS4或iOS5。注意:其中Mac OS X v10.6和iOS4不支持weak references(弱引用,后面会说明什么是weak references)。 Xcode 4.2提供了一个名为“Convert to Objective-C Automatic Reference Counting”的工具,在Edit->Convert menu下,可以帮你自动将使用Manual Reference Counting的老代码转换成使用ARC的新代码(例如去掉对retain和release的调用)。 或者将系统的版本调高。project->info->ios Deployment Target 

上一篇:shell脚本中自动输入用户名和密码
下一篇:Cracking the coding interview--Q2.5

相关文章

相关评论