在 linux 上部署并运行 JavaFX 项目

发布时间:2017-4-29 1:58:24 编辑:www.fx114.net 分享查询网我要评论
本篇文章主要介绍了"在 linux 上部署并运行 JavaFX 项目 ",主要涉及到在 linux 上部署并运行 JavaFX 项目 方面的内容,对于在 linux 上部署并运行 JavaFX 项目 感兴趣的同学可以参考一下。

环境

redhat 6.4、eclipse安装JavaFX插件

项目详情及代码参见 在linux上配置并创建JavaFX项目 ,该部署即此文章中项目的部署

配置build.fxbuild

clip_image001

clip_image003

 

生成build.xml

clip_image005

点击 ant build.xml only 在项目根目录下生成build文件夹

clip_image006

编辑build.xml

以此种方式生成的build.xml已经将复制jre的工作包含了,直接运行即可。

clip_image008

如果项目有其他的文件,比如图片等,可以修改build.xml将资源包含进去。

安装

# rpm -ivh oraclecheck-1.0-1.x86_64.rpm

error: Failed dependencies:

ld-linux.so.2 is needed by oraclecheck-1.0-1.x86_64

libX11.so.6 is needed by oraclecheck-1.0-1.x86_64

libXext.so.6 is needed by oraclecheck-1.0-1.x86_64

libXi.so.6 is needed by oraclecheck-1.0-1.x86_64

libXrender.so.1 is needed by oraclecheck-1.0-1.x86_64

libXtst.so.6 is needed by oraclecheck-1.0-1.x86_64

libasound.so.2 is needed by oraclecheck-1.0-1.x86_64

libc.so.6 is needed by oraclecheck-1.0-1.x86_64

libdl.so.2 is needed by oraclecheck-1.0-1.x86_64

libgcc_s.so.1 is needed by oraclecheck-1.0-1.x86_64

libm.so.6 is needed by oraclecheck-1.0-1.x86_64

libpthread.so.0 is needed by oraclecheck-1.0-1.x86_64

libthread_db.so.1 is needed by oraclecheck-1.0-1.x86_64

首次安装自制的 rpm 包会遇到缺少依赖包的问题,此处安装以下依赖包即可。

# yum install -y ld-linux.so.2

# yum install -y libX11.so.6

# yum install -y libXext.i686 --setopt=protected_multilib=false

# yum install -y libXi.i686 --setopt=protected_multilib=false

# yum install -y libXrender.i686 --setopt=protected_multilib=false

# yum install -y libXtst.i686 --setopt=protected_multilib=false

libasound.so.2 对应的rpm为 alsa-lib

# yum install -y alsa-lib.i686

# yum install -y libgcc.i686

# rpm -ivh oraclecheck-1.0-1.x86_64.rpm

Preparing... ########################################### [100%]

1:oraclecheck ########################################### [100%]

 

运行

中文乱码

中文乱码处理,Java类的编码为UTF-8,linux上运行时设置其为GBK

# export LANG=zh_CN.GBK

JDK环境

# java -version

java version "1.7.0_09-icedtea"

OpenJDK Runtime Environment (rhel-2.3.4.1.el6_3-x86_64)

OpenJDK 64-Bit Server VM (build 23.2-b09, mixed mode)

系统JDK为1.7,项目JDK为1.8,但打包时已经将jre打包到了rpm中,因此也不需要额外配置或修改已有的JDK环境变量。

查看安装位置

# rpm -qpl oraclecheck-1.0-1.x86_64.rpm

/opt/OracleCheck

[[email protected] OracleCheck]# cd /opt/OracleCheck

[[email protected] OracleCheck]# ll

总用量 616

drwxr-xr-x 2 root root 4096 11月 18 09:42 app

-r--r--r-- 1 root root 598718 11月 18 09:23 libpackager.so

-rwxr-xr-x 1 root root 10382 11月 18 09:23 OracleCheck

-rw-r--r-- 1 root root 170 11月 18 09:23 OracleCheck.desktop

-r--r--r-- 1 root root 2505 11月 18 09:23 OracleCheck.png

drwxr-xr-x 3 root root 4096 11月 18 09:42 runtime

[[email protected] OracleCheck]# ls runtime/

COPYRIGHT lib LICENSE README THIRDPARTYLICENSEREADME-JAVAFX.txt THIRDPARTYLICENSEREADME.txt Welcome.html

运行

[[email protected] OracleCheck]# ./OracleCheck

clip_image011

上一篇:Nginx 配置简述
下一篇:Sort命令使用

相关文章

相关评论

本站评论功能暂时取消,后续此功能例行通知。

一、不得利用本站危害国家安全、泄露国家秘密,不得侵犯国家社会集体的和公民的合法权益,不得利用本站制作、复制和传播不法有害信息!

二、互相尊重,对自己的言论和行为负责。

好贷网好贷款